Problems in View and Editor with Firefox browsers

Incident Report for Genially

Resolved

This incident has been resolved.
Posted May 09, 2025 - 11:53 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted May 09, 2025 - 11:13 UTC

Investigating

We detected an issue when users open their creations to edit or share
Posted May 09, 2025 - 10:54 UTC
This incident affected: Editor and View.