Genially Viewer Not Working on Certain Browsers

Incident Report for Genially

Resolved

This incident has been resolved.
Posted Feb 19, 2026 - 11:53 UTC

Identified

We have identified the root cause of the issue affecting the Genially viewer on certain browsers. A fix has been implemented and is currently being deployed.

We will continue monitoring the situation to ensure full resolution. Thank you for your patience.
Posted Feb 19, 2026 - 11:29 UTC

Investigating

The Genially viewer is failing to load or display content properly on some browsers. Users may experience blank screens, loading issues, or incomplete rendering. Investigation is needed to identify browser compatibility or recent update conflicts.
Posted Feb 19, 2026 - 10:48 UTC
This incident affected: View.